top 50 comments

sorted by: hot top controversial new old
[–] 95 points 1 year ago* (last edited 1 year ago) (12 children)

I scored 16/21 on https://e-mail.wtf/ and all I got was this lousy text to share on social media.

This was fun!

Edit: people, upvote the OP, not me

  • source
  • hideshow 12 child comments
  • [–] 51 points 1 year ago (5 children)

    13/21 here. Mostly got hung up on several "this was valid in earlier RFC, and later removed" kind of situations. There are several where I picked the correct answer, but where I know many websites that won't accept it as valid, and that's not even the more esoteric ones.

  • source
  • parent
  • hideshow 5 child comments
  • [–] 36 points 1 year ago (4 children)

    Yeah I feel like the correct answer for anything obsoleted by a more recent RFC should be "Invalid".

  • source
  • parent
  • hideshow 4 child comments
  • [–] 24 points 1 year ago* (2 children)

    But they will work, and according to the spec, you have to build your system so that it can handle those cases. Obsolete doesn't mean incorrect or invalid, just a "you shouldn't do this any more".

    Obsolete Syntax
    Earlier versions of this standard allowed for different (usually more liberal) syntax than is allowed in this version. Also, there have been syntactic elements used in messages on the Internet whose interpretation have never been documented. Though some of these syntactic forms MUST NOT be generated according to the grammar in section 3, they MUST be accepted and parsed by a conformant receiver.

    https://datatracker.ietf.org/doc/html/rfc2822#section-4

  • source
  • parent
  • hideshow 2 child comments
  • [–] 11 points 1 year ago

    Some of those "obsolete" things are outright blocked for specific reasons. For example, routing addresses through multiple servers. It was abused by spammers, so it's almost always denied these days.

    Looks like this:

    <@foo.example.com@bar.example.com:123@example.com>
    
  • source
  • parent
  • load more comments (1 reply)
  • load more comments (6 replies)
    [–] 74 points 1 year ago (1 child)

    THIS THING IS STUPID!!!!

    Or it’s just me that is the fool. Thanks for sharing. I just learned about 9 new things.

  • source
  • hideshow 1 child comment
  • [–] 41 points 1 year ago*

    All of the modern internet is built on the decaying carcasses of temporary solutions and things that seemed like a good idea at the moment but are now too widely used to change.

  • source
  • parent
  • [–] 68 points 1 year ago (7 children)

    I don't think it really matters what the standard is, because you'll be completely limited by some 25 year old bit of Regex from Stack Overflow that every web developer ever has implemented into their form sanity checks.

  • source
  • hideshow 7 child comments
  • [–] 22 points 1 year ago (6 children)

    The main one that gets passed around will match the weirdness fine. In fact, it probably matches things you don't want, anyway.

    A signin/registration form really only needs to do sanity checks to get rid of obviously bad addresses. You'll have to send a round-trip email confirmation message to make sure the email is real, anyway, so why bother going into great detail? Just check that there's an '@' symbol and a dot in the domain. Most of the rest is wanking off.

  • source
  • parent
  • hideshow 6 child comments
  • [–] 61 points 1 year ago* (last edited 1 year ago) (8 children)

    Question 5 is incorrect, name@example is a fully valid email address, even after RFC 2822

    The spec of RFC 2822 defines an address (3.4.1) as:

    local-part "@" domain
    

    domain is defined (3.4.1) as:

    domain = dot-atom / domain-literal / obs-domain
    

    dot-atom is defined (3.2.4) as:

    dot-atom = [CFWS] dot-atom-text [CFWS]
    dot-atom-text = 1*atext *("." 1*atext)
    

    1*atext meaning at least 1 alphanumeric character, followed by *("." 1*atext) meaning at least 0 "." 1*atext


    If tomorrow, google decided to use its google top-level domain as an email domain, it would be perfectly valid, as could any other company owning top-level domains

    Google even owns a gmail TLD so I wouldn't even be surprised if they decided to use it

  • source
  • hideshow 8 child comments
  • [–] 25 points 1 year ago (3 children)

    I don't know if they changes the answer to the question, but it now says name@example is valid.

  • source
  • parent
  • hideshow 3 child comments
  • load more comments (1 reply)
  • load more comments (4 replies)
    [–] 55 points 1 year ago (5 children)

    I don't care who the IRS sends, I am not validating emails with spaces on them.

  • source
  • hideshow 5 child comments
  • [–] 21 points 1 year ago (4 children)

    You shouldn’t be validating emails yourself anyway. Use a library or check for only the @ and then send an email confirmation.

  • source
  • parent
  • hideshow 4 child comments
  • load more comments (2 replies)
  • [+] 49 points 1 year ago* (last edited 11 months ago) (1 child)
  • [–] 47 points 1 year ago (4 children)

    What if we 👉@👈 ..? 🤭

  • source
  • hideshow 4 child comments
  • load more comments (4 replies)
    [–] 40 points 1 year ago* (2 children)

    Two of my "favorite" features it didn't even touch on. You can have nested comments:

    foo(one(two(three(four(five(six(seven)))))))@example.com
    

    This will actually fail on that big email regex that gets copied around (originally from Mastering Regular Expressions in 1997), because it can only handle comment nesting to a depth of six. It is actually possible to do indefinite nesting now with recursive regex, but it was developed before that feature existed.

    RFC822 also allows routing addresses through multiple servers:

    <@foo.example.com@bar.example.com:123@example.com>
    

    But this is almost always denied on modern email servers because it was abused by spammers.

  • source
  • hideshow 2 child comments
  • load more comments (2 replies)
    [–] 35 points 1 year ago (9 children)

    I don't validate emails, I test them.

    That's your email? OK, what did we send it? if we couldn't send to it or the user can't read it there's no reason to accept it.

    OK, maybe I do some light validation first, but I don't trust the email address just because it's email-address-shaped.

  • source
  • hideshow 9 child comments
  • load more comments (9 replies)
    [–] 34 points 1 year ago* (last edited 1 year ago) (3 children)

    My top five from this (all valid):

    • ":(){␣:|:&␣};:"@example.com # fork bomb
    • 👉@👈 and poop@[💩]
    • "@"@[@]
    • c̷̨̈́i̵̮̅l̶̠̐͊͝ȁ̷̠̗̆̍̍n̷͖̘̯̍̈͒̅t̶͍͂͋ř̵̞͈̓ȯ̷̯̠-̸͚̖̟͋s̴͉̦̭̔̆̃͒û̵̥̪͆̒̕c̸̨̨̧̺̎k̵̼͗̀s̸̖̜͍̲̈́͋̂͠@example.com
    • fed-up-yet@␣example.com␣ # ␣ = whitespace
  • source
  • hideshow 3 child comments
  • load more comments (2 replies)
    [–] 28 points 1 year ago (2 children)

    I gave up when I got like 5 wrong. I've ran mail servers for decades, most of the invalid "valids" would get rejected by any mailservers I've administered.

  • source
  • hideshow 2 child comments
  • load more comments (2 replies)
    [–] 27 points 1 year ago (1 child)

    I had to make an email address just for paypal because those idiots don't accept subdomains in email addresses.

  • source
  • hideshow 1 child comment
  • [–] 27 points 1 year ago (3 children)

    Let us recite the email validator’s oath:

    If it has something before the @, something between the @ and the ., and something after the ., it’s valid enough.

  • source
  • hideshow 3 child comments
  • load more comments (3 replies)
    [–] 27 points 1 year ago (1 child)

    I scored 13/21 on https://e-mail.wtf/ and all I got was this lousy text to share on social media.

  • source
  • hideshow 1 child comment
  • load more comments (1 reply)
    [–] 25 points 1 year ago

    I scored 16/21 on https://e-mail.wtf/ and all I got was this lousy text to share on social media.

    Damn, and here I thought I had this locked down because I was salty that so many places struggle with + in the email addy. But my god, there's comments?

  • source
  • [–] 24 points 1 year ago (1 child)

    Thanks to RFC 6532, Zalgo text is a-okay.

    hmmm...

    Yay! You're average! Time to start making plans for what you'll do when an LLM takes your job.

    I already have plans.

  • source
  • hideshow 1 child comment
  • load more comments (1 reply)
    [–] 24 points 1 year ago (5 children)

    14 / 21

    This is the score you get when you answer "valid" for every question. Good job.

  • source
  • hideshow 5 child comments
  • load more comments (4 replies)
    [–] 22 points 1 year ago (13 children)

    Also as the registrant of one of those new fancy TLDs, much like the owner of this website (email.wtf), their own email addresses will fail those stupid email validation checks that only believe in example@example.[com|net|org]

    Shitty websites will fail "example@email.wtf", guaranteed - despite it being 100% valid AND potentially live.

    Source - I have a ".family" domain for my email server. Totally functional, but some shitty websites refuse to believe it.

  • source
  • hideshow 13 child comments
  • load more comments (13 replies)
    [–] 21 points 1 year ago

    I lost it at the fork bomb. I mean I hit valid because there was no way it was on the and not valid, but there's no way i'd have expected that. after that I just kept guessing the most stupid answer and did pretty well

  • source
  • [–] 19 points 1 year ago (1 child)

    nice. though valid but obsolete is not a thing... if it's obsolete it's invalid.

  • source
  • hideshow 1 child comment
  • load more comments (1 reply)
    [–] 16 points 1 year ago (2 children)

    13 right answers and I didn't expect so many lol

    I'll never validate some of the 💩 I've learnt today.

  • source
  • hideshow 2 child comments
  • load more comments (2 replies)
    [–] 14 points 1 year ago (1 child)

    Tap for spoilerEmail addresses can have comments?!

  • source
  • hideshow 1 child comment
  • load more comments (1 reply)
    [–] 14 points 1 year ago

    I scored 14/21 on https://e-mail.wtf/ and all I got was this lousy text to share on social media.

    I actually died at the poop emoji one. Actually amazing awareness to test for that

  • source
  • [–] 14 points 1 year ago

    Pretty much everything I've seen in e-mail is needlessly complicated and weird. So of course addresses are as well.

  • source
  • [–] 14 points 1 year ago (1 child)

    13/21, seems like I am not significantly different from random guessing

  • source
  • hideshow 1 child comment
  • load more comments (1 reply)
    [–] 13 points 1 year ago

    I scored 16/21 on https://e-mail.wtf/ and all I got was this lousy text to share on social media.

    I feel pretty good about that

  • source
  • [–] 12 points 1 year ago* (1 child)

    15

    Going to have to try some of those.... Can you actually register emojis as a domain, or is that just the email validation that allows them?

    Edit: most TLDs don't. Smaller ones do sometimes.

  • source
  • hideshow 1 child comment
  • load more comments (1 reply)
    [–] 10 points 1 year ago (3 children)

    12/21

    are things that are considered out of current spec really "valid" though?

  • source
  • hideshow 3 child comments
  • load more comments (3 replies)
    load more comments
    view more: next ›