Ok, just to confirm I understand correctly:
- after power up you don't choose different UEFI entry, just wait for the regular (sda2) grub to come up. Same as when booting up MX
- you choose the option
postmarketOS v26.06 (on /dev/sda7) - then you get the error from the earlier photo?
If all of that is correct, then:
- it seems that some kernel starts fine and it's even Alpine. It's either reading the root partition or running the init that breaks
you went with SysV or Systemd? - the kernel you want to run is on sda6 and is named
vmlinuz-lts? - there is no
initrdfile in sda6? - I'm not sure if using
/dev/sda7isn't too early
for a test replacedev/sda7in line 249 with(hd0,gpt7)
Ideally it should be partition's UUID like in the earlier entries but without the UUIDs from earlier point I don't know the string to pass to you - your sda6 is FAT, while sda7 is EXT. What happens if you add
insmod ext2after line 242?